Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-13589

libmariadbclient18 is broken when using mariadb repo instead of debian's

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 10.1.24, 10.1.25, 10.1.26, 10.1.27, 10.1.28, 10.2.7, 10.2.8
    • Fix Version/s: 10.2.9
    • Component/s: libmariadb, Platform Debian
    • Labels:
      None
    • Environment:
      debian stretch 9.1

      Description

      Hi, when using libmariadbclient18 from mariadb repo, it causes it to not work on debian. I found this problem when using icinga2 as it is complaining with this error

      [2017-08-19 15:46:37 +0000] critical/config: Error: Error while evaluating expression: Could not load library 'libdb_ido_mysql.so.2.7.0': libmariadbclient.so.18: cannot open shared object file: No such file or directory
      

      But if i use libmariadbclient18 from debian https://packages.debian.org/stretch/amd64/libmariadbclient18/download it works.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              serg Sergei Golubchik
              Reporter:
              paladox paladox
              Votes:
              5 Vote for this issue
              Watchers:
              10 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: