Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-13114

New MariaDB 10.2 connection always has wait_timeout=28800, does not use global value

    XMLWordPrintable

    Details

      Description

      Let's say that I do the following:

      [ec2-user@ip-172-30-0-58 ~]$ mysql -u root
      Welcome to the MariaDB monitor.  Commands end with ; or \g.
      Your MariaDB connection id is 22
      Server version: 10.2.6-MariaDB MariaDB Server
       
      Copyright (c) 2000, 2017, Oracle, MariaDB Corporation Ab and others.
       
      Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
       
      MariaDB [(none)]> SET GLOBAL wait_timeout=600;
      Query OK, 0 rows affected (0.00 sec)
       
      MariaDB [(none)]> \q
      Bye
      

      The above command set the global value for wait_timeout to 600, so new sessions should use this value. However, they still seem to use the default value in 10.2.6:

      [ec2-user@ip-172-30-0-58 ~]$ mysql -u root
      Welcome to the MariaDB monitor.  Commands end with ; or \g.
      Your MariaDB connection id is 23
      Server version: 10.2.6-MariaDB MariaDB Server
       
      Copyright (c) 2000, 2017, Oracle, MariaDB Corporation Ab and others.
       
      Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
       
      MariaDB [(none)]> SHOW GLOBAL VARIABLES LIKE 'wait_timeout';
      +---------------+-------+
      | Variable_name | Value |
      +---------------+-------+
      | wait_timeout  | 600   |
      +---------------+-------+
      1 row in set (0.00 sec)
       
      MariaDB [(none)]> SHOW SESSION VARIABLES LIKE 'wait_timeout';
      +---------------+-------+
      | Variable_name | Value |
      +---------------+-------+
      | wait_timeout  | 28800 |
      +---------------+-------+
      1 row in set (0.00 sec)
       
      MariaDB [(none)]> \q
      Bye
      

      For whatever reason, other variables like interactive_timeout and connect_timeout do not have the same problem.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            GeoffMontee Geoff Montee
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Git Integration

                Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.