Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-13037

wsrep_sst_mysqldump checking wrong version of mysql client

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 10.2.6
    • Fix Version/s: 10.2.8
    • Component/s: Galera SST
    • Labels:
    • Environment:
      debian 9 (stretch) x64 , vmware guest , packages installed from apt repository , version of packages : 10.2.6+maria~stretch ; galera-3 25.3.20-stretch

      Description

      when using mysqldump as sst method it fails with error
      "this operation requires MySQL client version 10 or newer"

      This happens because on line 59 of /usr/bin/wsrep_sst_mysqldump we have a check :

      "if ! $MYSQL_CLIENT --version | grep 'Distrib 10.1' >/dev/null"

      but the client is 10.2 so it doesnt match the grep expression ,
      here is the output of mysqlclient --version :

      mysql --version
      mysql Ver 15.1 Distrib 10.2.6-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2

      a possible fix could be to change the condition to

      "if ! $MYSQL_CLIENT --version | grep 'Distrib 10.' >/dev/null"

      so that every 10. version is accepted

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              jplindst Jan Lindström
              Reporter:
              shert Mario Caruso
              Votes:
              1 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: