Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-11715

debian wheezy repository with wrong Packages file

    Details

      Description

      When trying to update mariadb-client mariadb-server from anyone of the mirrors you would get an error:

      The following packages have unmet dependencies:
       mariadb-client : Depends: mariadb-client-10.1 (= 10.1.20+maria-1~wheezy) but 10.1.19+maria-1~wheezy is to be installed
       mariadb-server : Depends: mariadb-server-10.1 (= 10.1.20+maria-1~wheezy) but 10.1.19+maria-1~wheezy is to be installed
      E: Unable to correct problems, you have held broken packages.
      

      Inspecting the Packages file on the servers shows:

      Package: mariadb-client-10.1
      Version: 10.1.19+maria-1~wheezy
      Conflicts: mariadb-client (<< 10.1.19+maria-1~wheezy), mariadb-client-10.0, mariadb-client-5.1, mariadb-client-5.2, mariadb-client-5.3, mariadb-client-5.5, mysql-client (<< 5.0.51), mysql-client-5.0, mysql-client-5.1, mysql-client-5.5, mysql-client-5.6, virtual-mysql-client
      Replaces: mariadb-client (<< 10.1.19+maria-1~wheezy), mariadb-client-10.0, mariadb-client-5.1, mariadb-client-5.2, mariadb-client-5.3, mariadb-client-5.5, mysql-client (<< 5.0.51), mysql-client-5.0, mysql-client-5.1, mysql-client-5.5, mysql-client-5.6, virtual-mysql-client
      

      It seams the Version line is not updated to the new version

      The amd64 shows it correctly 
      Package: mariadb-client-10.1
      Version: 10.1.20+maria-1~wheezy
      Depends: debianutils (>= 1.6), libdbd-mysql-perl (>= 1.2202), libdbi-perl, libmariadbclient18 (>= 10.1.20+maria-1~wheezy), mariadb-client-core-10.1 (>= 10.1.20+maria-1~wheezy), mariadb-common, perl, libc6 (>= 2.4), libssl1.0.0 (>= 1.0.0), libstdc++6 (>= 4.1.1), zlib1g (>= 1:1.1.4)
      Suggests: libterm-readkey-perl
      Conflicts: mariadb-client (<< 10.1.20+maria-1~wheezy), mariadb-client-10.0, mariadb-client-5.1, mariadb-client-5.2, mariadb-client-5.3, mariadb-client-5.5, mysql-client (<< 5.0.51), mysql-client-5.0, mysql-client-5.1, mysql-client-5.5, mysql-client-5.6, virtual-mysql-client
      Replaces: mariadb-client (<< 10.1.20+maria-1~wheezy), mariadb-client-10.0, mariadb-client-5.1, mariadb-client-5.2, mariadb-client-5.3, mariadb-client-5.5, mysql-client (<< 5.0.51), mysql-client-5.0, mysql-client-5.1, mysql-client-5.5, mysql-client-5.6, virtual-mysql-client
      

        Attachments

          Activity

            People

            • Assignee:
              dbart Daniel Bartholomew
              Reporter:
              lukav Anton Avramov
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: