The old libmariadbclient18 package included libmariadbclient.so.18. The development package included dynamic libmariadbclient.so and static libmariadbclient.a.
In the new Connnector/C we have dynamic libmariadb.so and libmariadbclient.a. This name mismatch is really confusing for humans using this library, and it creates conflicts in packages as files overwrite each other in wrong places. Please rename the static library to libmariadb.a.
There has been a patch for this since 2014 (does not apply anymore): https://anonscm.debian.org/cgit/pkg-mysql/mariadb-connector-c.git/tree/debian/patches/rename_static_lib.patch?id=08de8a73c371d4fbbccb1bd8ffb739acf64867db