Uploaded image for project: 'MariaDB MaxScale'
  1. MariaDB MaxScale
  2. MXS-7581

Review the default Restart setting in the MaxScale systemd service configuration.

    XMLWordPrintable

Details

    • Bug
    • Status: Open (View Workflow)
    • Major
    • Resolution: Unresolved
    • None
    • None
    • build
    • None

    Description

      The MaxScale systemd service currently uses the following configuration:

       
      cat /usr/lib/systemd/system/maxscale.service
       
      [Service]
      Type=forking
      Restart=on-abort
      

      In any environment , if MaxScale stopped responding and systemd stopped the service due to a watchdog failure.

      With Restart=on-abort, the MaxScale service was not automatically restarted after the watchdog failure. As a result, MaxScale remained down until it was manually started.

      Expected Behavior

      MaxScale should automatically restart when it is terminated unexpectedly, including cases where systemd stops the service due to a watchdog failure.

      Is Restart=on-abort the intended default value for MaxScale?

      What is the recommended Restart value for MaxScale to handle watchdog and unexpected failures?

      Should the default MaxScale systemd service configuration be changed to use a value such as Restart=always?

      Reference

      systemd service documentation: https://www.freedesktop.org/software/systemd/man/latest/systemd.service.html

      Attachments

        Activity

          People

            Unassigned Unassigned
            pramod.mahto@mariadb.com Pramod Mahto
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:

              Git Integration

                Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.