Details
Description
Upgrade Steps For Fixed Versions
When upgrading from an affected version, first upgrade to the latest patch version, do a configuration change and only then upgrade the major version. For example, upgrading from 23.08.9 to the latest 25.10 release 25.10.3:
- Upgrade MaxScale from 23.08.9 to 23.08.14
- Toggle log_info with execute maxctrl alter maxscale log_info=true followed by maxctrl alter maxscale log_info=false
- Upgrade MaxScale from 23.08.14 to 25.10.3
Original Problem
After upgrade for example from 22.08 to 25.01.6 starting maxscale fails with:
2026-03-27 13:31:34 error : (ConfigManager); readwritesplit: The parameter 'optimistic_trx' is unrecognized.
|
2026-03-27 13:31:34 error : (ConfigManager); readwritesplit: The parameter 'reuse_prepared_statements' is unrecognized.
|
2026-03-27 13:31:34 error : (ConfigManager); Could not create service 'Read-Write-Service' with module 'readwritesplit'
|
To overcome this we had to manually remove the parameters from the JSON object via a stored procedure.
Also after fixing the above parameters another issue arised, Maxscale reported skip_permission_checks as unrecognized, even though it wasn’t explicitly set. After manually setting it to null it started.
I guess maxscale upgrade should take care of removing the deprecated options for the json object on a pre-flight check upon restart or ignore deprecated options, a post upgrade script would require db connection parameters imho a bit not elegant.
Attachments
Issue Links
- causes
-
MXS-6705 Configuration synchronization unnecessarily destroys all objects
-
- Closed
-