Details
-
Bug
-
Status: Closed (View Workflow)
-
Critical
-
Resolution: Fixed
-
N/A
-
Can result in data loss
Description
saahil reported a crash with a test case that I simplified as follows:
--source include/have_innodb.inc
|
--source include/have_sequence.inc
|
|
|
SET GLOBAL innodb_log_archive=OFF; |
SET GLOBAL innodb_log_file_size=4*1024*1024; |
|
|
CREATE TABLE t (a SERIAL, b CHAR(255) NOT NULL) ENGINE=InnoDB; |
|
|
SET GLOBAL innodb_log_archive=ON; |
SET GLOBAL innodb_log_file_size=8*1024*1024; |
|
|
INSERT INTO t SELECT SEQ,REPEAT('x',255) FROM seq_1_to_65536; |
DROP TABLE t; |
This leads to a debug assertion failure:
lsn_t log_t::write_checkpoint(lsn_t, lsn_t): Assertion `next_checkpoint_no == uint16_t(4 * is_encrypted()) || (C[-1] && my_betoh64(C[-1]) < d)' failed.
|
Attachments
Issue Links
- blocks
-
MDEV-14992 BACKUP SERVER to mounted file system
-
- In Progress
-
- is caused by
-
MDEV-37949 Implement innodb_log_archive
-
- Closed
-