Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-10512

main.mysqldump fails sporadically in buildbot

    Details

    • Sprint:
      10.0.28

      Description

      http://buildbot.askmonty.org/buildbot/builders/p8-rhel7-bintar/builds/1436/steps/test/logs/stdio
      http://buildbot.askmonty.org/buildbot/builders/work-amd64-valgrind/builds/8977
      http://askmonty.org/buildbot/builders/kvm-deb-wheezy-x86/builds/2975

      main.mysqldump 'innodb_plugin'           w4 [ fail ]
              Test ended at 2016-08-02 17:06:18
       
      CURRENT_TEST: main.mysqldump
      mysqldump: Couldn't find table: "non_existing"
      mysqldump: Got error: 1356: "View 'test.v1' references invalid table(s) or column(s) or function(s) or definer/invoker of view lack rights to use them" when using LOCK TABLES
      mysqldump: Couldn't execute 'SHOW FIELDS FROM `v1`': View 'test.v1' references invalid table(s) or column(s) or function(s) or definer/invoker of view lack rights to use them (1356)
      mysqldump: Got error: 1083: "Field separator argument is not what is expected; check the manual" when executing 'SELECT INTO OUTFILE'
      mysqldump: Got error: 1083: "Field separator argument is not what is expected; check the manual" when executing 'SELECT INTO OUTFILE'
      mysqldump: Got error: 1083: "Field separator argument is not what is expected; check the manual" when executing 'SELECT INTO OUTFILE'
      mysqldump: user2 has insufficent privileges to SHOW CREATE PROCEDURE `sp1`!
      mysqldump: Got error: 1146: "Table 'test.???????????????????????' doesn't exist" when using LOCK TABLES
      mysqlimport: ../nptl/pthread_mutex_lock.c:81: __pthread_mutex_lock: Assertion `mutex->__data.__owner == 0' failed.
      mysqltest: At line 1762: exec of '/home/buildbot/maria-slave/power8-vlp03-bintar/build/client/mysqlimport --defaults-file=/home/buildbot/maria-slave/power8-vlp03-bintar/build/mysql-test/var/4/my.cnf --silent --use-threads=5 test /home/buildbot/maria-slave/power8-vlp03-bintar/build/mysql-test/var/4/tmp/t1.txt /home/buildbot/maria-slave/power8-vlp03-bintar/build/mysql-test/var/4/tmp/t2.txt' failed, error: 6, status: 0, errno: 0
      Output from before failure:
      test.t1: Records: 2  Deleted: 0  Skipped: 0  Warnings: 0
      test.t2: Records: 2  Deleted: 0  Skipped: 0  Warnings: 0
       
       
       
      The result from queries just before the failure was:
      < snip >
      /*!40101 SET COLLATION_CONNECTION=@OLD_COLLATION_CONNECTION */;
      /*!40111 SET SQL_NOTES=@OLD_SQL_NOTES */;
       
      DROP TABLE t1;
      create table t1 (a text , b text);
      create table t2 (a text , b text);
      insert t1 values ("Duck, Duck", "goose");
      insert t1 values ("Duck, Duck", "pidgeon");
      insert t2 values ("We the people", "in order to perform");
      insert t2 values ("a more perfect", "union");
      select * from t1;
      a	b
      Duck, Duck	goose
      Duck, Duck	pidgeon
      select * from t2;
      a	b
      We the people	in order to perform
      a more perfect	union
      test.t1: Records: 2  Deleted: 0  Skipped: 0  Warnings: 0
      test.t2: Records: 2  Deleted: 0  Skipped: 0  Warnings: 0
      

      ~15 recorded occurrences over 1.5 years, on different builders.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                svoj Sergey Vojtovich
                Reporter:
                elenst Elena Stepanova
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: