Uploaded image for project: 'MariaDB MaxScale'
  1. MariaDB MaxScale
  2. MXS-3406

Default value of connector_plugindir can cause problems

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Incomplete
    • Affects Version/s: None
    • Fix Version/s: N/A
    • Component/s: N/A
    • Labels:
      None

      Description

      The default value for connector_plugindir is /usr/lib64/mysql/plugin which normally contains plugins for the server. If the server requests authentication using a plugin and that plugin exists in the default location, it is possible that an unsupported version of the plugin is used.

      If we want to support authentication of monitor connections with different client-side plugins, the plugins built for the version used by MaxScale should be included in the package itself. If we don't want to support it (or before we include them in the package), the path should point somewhere where we know the plugins won't be.

        Attachments

          Activity

            People

            Assignee:
            markus makela markus makela
            Reporter:
            markus makela markus makela
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Git Integration