Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-29476

MariaDB replication hangs without any error

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Incomplete
    • Affects Version/s: 10.1.22, 10.3.18
    • Fix Version/s: N/A
    • Component/s: Replication
    • Labels:
    • Environment:
      SMP Debian 4.9.144-3 (2019-02-02) x86_64 GNU/Linux

      Description

      one master , five slaves( it does not matter, it occurs when there is one of the slave ).
      slave config:
      slave_parallel_threads = 8
      log-slave-updates = 1
      it goes well for a long time , however all of the slaves do not work and stopd at a same position P(gtid_binlog_pos), as follows :
      when execute SHOW SLAVE STATUS , the Seconds_Behind_Master is allways 0 ,the Slave_IO_Running and Slave_SQL_Running is Yes.the gtid_slave_pos and gtid_current_pos changed but the gtid_binlog_pos does not change.
      when create a test table and insert a test sql , they do replcate DDL, but they do not replicate DML.
      when create a new instance as slave, and restore the old slave's sql backup of yesterday into the new slave, then execute CHANGE MASTER ,it still does not work。
      when create a new instance as slave, and restore the master's sql backup of now into the new slave, then execute CHANGE MASTER ,it still does not work。
      when restart(stop slave, reset slave all, change master to P ) the slaves or restart the slave's MySQL daemon , it still does not work.
      then we restart the master , all of the slaves goes wrong (because the replication position is wrong).

        Attachments

          Activity

            People

            Assignee:
            angelique.sklavounos Angelique Sklavounos
            Reporter:
            aylen Aylen Wang
            Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Git Integration

                Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.