Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-26018

Update breaks cluster

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Won't Fix
    • Affects Version/s: 10.4.20
    • Fix Version/s: N/A
    • Component/s: wsrep
    • Labels:
      None
    • Environment:
      Red Hat Enterprise Linux Server release 7.9 (Maipo)

      Linux 3.10.0-1160.25.1.el7.x86_64 #1 SMP Tue Apr 13 18:55:45 EDT 2021 x86_64 x86_64 x86_64 GNU/Linux

      3-node wsrep-cluster

      Description

      After updating from 10.4.19 > 10.4.20 I couldn't get any secondary nodes to join the cluster.
      I could see the nodes join and immediately leave again. See attached logs.

      I was able to resolve this by downgrading back to 10.4.19

        Attachments

        1. primary_donor.txt
          31 kB
        2. primary_donor.txt
          9 kB
        3. secondary_joiner.txt
          30 kB
        4. secondary_joiner.txt
          15 kB
        5. server.cnf
          3 kB

          Activity

            People

            Assignee:
            seppo Seppo Jaakola
            Reporter:
            tvdijen Tim van Dijen
            Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Git Integration

                Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.