Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-25181

Improvement suggestion: 60-galera.cnf comes without wsrep_provider

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 10.5.9
    • Fix Version/s: 10.5
    • Component/s: Configuration, Galera
    • Labels:
      None
    • Environment:
      Debian 10, CentOS 8 and Ubuntu 20.04

      Description

      When a Galera Cluster is installed a Galera config (60-galera.cnf) is provided:

      [galera]

      1. Mandatory settings
        #wsrep_on = ON
        #wsrep_cluster_name = "MariaDB Galera Cluster"
        #wsrep_cluster_address = gcomm://
        #binlog_format = row
        #default_storage_engine = InnoDB
        #innodb_autoinc_lock_mode = 2
      1. Allow server to accept connections on all interfaces.
        #bind-address = 0.0.0.0
      1. Optional settings
        #wsrep_slave_threads = 1
        #innodb_flush_log_at_trx_commit = 0

      In this config some outcommented variables are set. But wsrep_provider is missing!!! Without this variable the node will not start with the Galera plug-in enabled. It took me a few minutes to find out, what was missing. I guess that some newbies will take much longer and give up frustrated?

      Suggestion: Add # wsrep_provider = /usr/lib/libgalera_smm.so to the config so we do not forget the parameter.

        Attachments

          Activity

            People

            Assignee:
            jplindst Jan Lindström
            Reporter:
            oli Oli Sennhauser
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:

                Git Integration