Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-24189

Rename Table twice raise error "Tablespace is missing for a table"



    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Not a Bug
    • 10.5.7
    • N/A
    • None
    • Windows docker container only. Not Linux, not windows native


      From: https://github.com/docker-library/mariadb/issues/331

      Run docker-compose up -d
      connect with your favorite client (I'm using DBeaver Enterprise)
      Run a create table statement:

      CREATE TABLE NewTable (
      ID int primary key,
      name varchar(10)

      Run a RENAME table statement like this:
      RENAME TABLE mytestdb.NewTable TO mytestdb.NewTablea;

      Then, run again, another RENAME the statement:
      RENAME TABLE mytestdb.NewTablea TO mytestdb.NewTableb;

      The error I'm getting is:
      SQL Error [1025] [HY000]: (conn=4) Error on rename of './mytestdb/newtablea' to './mytestdb/newtableb' (errno: 194 "Tablespace is missing for a table")

      1 - When I install the MariaDB client via .msi installer for windows, all works fine
      2 - I changed the variable lower_case_table_names to 1 because the default with windows is coming 2 for me, but with no success, the error still the same.
      3 - I created the same container with mysql:latest image instead of mariadb and all works fine
      4 - Tried to adjust folder permissions on windows, giving all permisions to anyone (like a chmod 777 on linux), but the erros still the same.

      So I think that there's some problem with windows + mariadb:latest image


        1. files.PNG
          9 kB
        2. ProcessMonitorLogfile.CSV
          7 kB
        3. rename.c
          0.2 kB
        4. rename.strace
          0.9 kB
        5. rename-wsl.strace
          3 kB
        6. script.sql
          0.3 kB
        7. strace.out
          23 kB
        8. WSL Disabled - Working with Hyper-V.png
          WSL Disabled - Working with Hyper-V.png
          39 kB

        Issue Links



              danblack Daniel Black
              danblack Daniel Black
              0 Vote for this issue
              6 Start watching this issue



                Git Integration

                  Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.