Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-24085

main.client_xml fails in buildbot with wrong result

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 10.5
    • Fix Version/s: 10.5
    • Component/s: Tests
    • Labels:
      None

      Description

      The failure happens in the buildbot rarely, once in a few months.

      http://buildbot.askmonty.org/buildbot/builders/win32-debug/builds/18074

      10.5 882ce206dbf06b771ffe4cbce2e3e421 win32-debug

      main.client_xml                          w3 [ fail ]
              Test ended at 2020-09-23 09:37:30
       
      CURRENT_TEST: main.client_xml
      --- D:/win32-debug/build/src/mysql-test/main/client_xml.result	2020-09-23 09:06:18.078353300 +0000
      +++ D:\win32-debug\build\src\mysql-test\main\client_xml.reject	2020-09-23 09:37:29.777318800 +0000
      @@ -8,16 +8,6 @@
       );
       insert into t1 values (1, 2, 'a&b a<b a>b');
       <?xml version="1.0"?>
      -
      -<resultset statement="select * from t1
      -" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      -  <row>
      -	<field name="a&amp;b">1</field>
      -	<field name="a&lt;b">2</field>
      -	<field name="a&gt;b">a&amp;b a&lt;b a&gt;b</field>
      -  </row>
      -</resultset>
      -<?xml version="1.0"?>
       <mysqldump xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
       <database name="test">
       	<table_structure name="t1">
       
      mysqltest: Result length mismatch
      

        Attachments

          Activity

            People

            Assignee:
            holyfoot Alexey Botchkov
            Reporter:
            elenst Elena Stepanova
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated: