Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-21450

ha_connect.so plugin broken

    XMLWordPrintable

    Details

      Description

      Hello,

      The Connect SE plugin can't be used after compilation.

      Previous 10.3 & 10.4 versions are not affected. The issue must have been introduced in those affected versions.

      Sample from the error log:
      (configured via config file with "log_warnings=9" and "plugin_load_add=ha_connect")

      [ERROR] mysqld: Can't open shared library '/usr/lib64/mariadb/plugin/ha_connect.so' (errno: 22, undefined symbol: _ZN6XMLDEFC1Ev)
      [ERROR] Couldn't load plugins from 'ha_connect.so'.
      [ERROR] mysqld: Can't open shared library '/usr/lib64/mariadb/plugin/ha_connect.so' (errno: 0, undefined symbol: _ZN6XMLDEFC1Ev)
      [ERROR] Couldn't load plugins from 'ha_connect.so'.
      [Note] Initializing built-in plugins
      [Note] Initializing plugins specified on the command line
      [ERROR] mysqld: Can't open shared library '/usr/lib64/mariadb/plugin/ha_connect.so' (errno: 22, undefined symbol: _ZN6XMLDEFC1Ev)
      [ERROR] Couldn't load plugins from 'ha_connect.so'.
      

      Result after running "mysql"

      # mysql
      mysql: unknown variable 'plugin_load_add=ha_connect'
      

      Also, the whole Connect testsuite fail on all affected versions:
      https://jira.mariadb.org/browse/MDEV-19786

      —

      I won't introduce the new versions to Fedora without a fix.

        Attachments

          Activity

            People

            Assignee:
            bertrandop Olivier Bertrand
            Reporter:
            mschorm Michal Schorm
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: