Uploaded image for project: 'MariaDB Connector/J'
  1. MariaDB Connector/J
  2. CONJ-725

Connection Failure for PAM user on 10.4

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.4.4
    • Component/s: authentication
    • Labels:
      None
    • Environment:
      Centos 7

      Description

      I was trialling 10.4 for our application which is a cloud based application running on AWS though our development environment is run under VMWare workstation 15.

      In production we have an openldap server, a database server, a tomcat server and an http server all running on Linux though in development the http and tomcat servers are on Windows within the eclipse environment. Tomcat is running 7.0.90.

      We have PAM configured on the database machine.

      In production we have 10.2.28. I have been experimenting with upgrading to 10.3 and then to 10.4. Unfortunately when I upgrade to 10.4 I get a connection error when connecting with a user defined as PAM as a pooled connection.

      A straight mysql -u user -p on the database server works fine.

      Are there any known problems with PAM on 10.4? Or indeed any additional configurations required. Or issues with authentication around connection pooling from tomcat 7.0?

        Attachments

          Activity

            People

            • Assignee:
              diego dupin Diego Dupin
              Reporter:
              nick.denning@diegesis.co.uk Nicholas Denning
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: