Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-20061

check libsepol versions on rpm builders

    XMLWordPrintable

    Details

      Description

      It seems that one can install (normally with yum) packages on CentOS X.Y (inparticular, 7.4) that aren't available for the corresponding RHEL X.Y — in particular, supposedly yum will pull libsepol-2.5-10.el7.x86_64.rpm from the CentOS 7.latest (7.6), even though RHEL 7.5 has at most libsepol 2.5-8.

      Since 578e822985a we use a versioned libsepol dependency in MariaDB-server.rpm packages, so for it to be installable on RHEL our CentOS builders must use libsepol that is available for RHEL.

      This task is to check libsepol versions installed on all rpm builders, make sure that it is available on RHEL, or downgrade libsepol if needed.

        Attachments

          Activity

            People

            Assignee:
            abychko Alexey Bychko
            Reporter:
            serg Sergei Golubchik
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: