Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-18346

Debian upgrade to 10.4 fails when the machine has Debian's galera/MariaDB packages installed

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 10.4
    • Fix Version/s: 10.4
    • Component/s: Platform Debian
    • Labels:
      None

      Description

      https://internal.askmonty.org/buildbot/builders/kvm-deb-stretch-amd64/builds/6585/steps/upgrade1/logs/stdio

      The following packages have unmet dependencies:
       mariadb-server : Depends: mariadb-server-10.4 (>= 1:10.4.2+maria~stretch) but it is not going to be installed
      

      When we start unwinding, it's actually

      The following packages have unmet dependencies:
       mariadb-server-10.4 : Depends: galera-4 (>= 26.4) but it is not going to be installed
      

      But if we install galera-4 explicitly, it works:

      udo apt-get install galera-4
      Reading package lists... Done
      Building dependency tree       
      Reading state information... Done
      The following packages were automatically installed and are no longer required:
        libarchive13 libcgi-fast-perl libcgi-pm-perl libdbd-mysql-perl libdbi-perl libencode-locale-perl libfcgi-perl libhtml-parser-perl libhtml-tagset-perl
        libhtml-template-perl libhttp-date-perl libhttp-message-perl libio-html-perl liblwp-mediatypes-perl libreadline5 libterm-readkey-perl libtimedate-perl
        liburi-perl mariadb-common mariadb-server-core-10.1 rsync socat
      Use 'sudo apt autoremove' to remove them.
      The following additional packages will be installed:
        mariadb-common
      The following packages will be REMOVED:
        galera-3 mariadb-client-10.1 mariadb-client-core-10.1 mariadb-server mariadb-server-10.1
      The following NEW packages will be installed:
        galera-4
      

      It happens on the builders which have galera-3 and MariaDB packaged by Debian:

      ii  galera-3                      25.3.19-2                      amd64        Replication framework for transactional applications
      ii  libdbd-mysql-perl             4.041-2                        amd64        Perl5 database interface to the MariaDB/MySQL database
      ii  libmariadbclient18:amd64      10.1.23-9+deb9u1               amd64        MariaDB database client library
      ii  mariadb-client-10.1           10.1.23-9+deb9u1               amd64        MariaDB database client binaries
      ii  mariadb-client-core-10.1      10.1.23-9+deb9u1               amd64        MariaDB database core client binaries
      ii  mariadb-common                10.1.23-9+deb9u1               all          MariaDB common metapackage
      ii  mariadb-server                10.1.23-9+deb9u1               all          MariaDB database server (metapackage depending on the latest version)
      ii  mariadb-server-10.1           10.1.23-9+deb9u1               amd64        MariaDB database server binaries
      ii  mariadb-server-core-10.1      10.1.23-9+deb9u1               amd64        MariaDB database core server files
      ii  mysql-common                  5.8+1.0.2                      all          MySQL database common files, e.g. /etc/mysql/my.cnf
      

      and doesn't happen when they're packaged by MariaDB:

      ii  galera-3                      25.3.20-stretch                amd64        Replication framework for transactional applications
      ii  libdbd-mysql-perl             4.041-2                        amd64        Perl5 database interface to the MariaDB/MySQL database
      ii  libmariadbclient18            10.1.23+maria-1~stretch        amd64        MariaDB database client library
      ii  libmysqlclient18              10.1.23+maria-1~stretch        amd64        Virtual package to satisfy external depends
      ii  mariadb-client-10.1           10.1.23+maria-1~stretch        amd64        MariaDB database client binaries
      ii  mariadb-client-core-10.1      10.1.23+maria-1~stretch        amd64        MariaDB database core client binaries
      ii  mariadb-common                10.1.23+maria-1~stretch        all          MariaDB database common files (e.g. /etc/mysql/conf.d/mariadb.cnf)
      ii  mariadb-server                10.1.23+maria-1~stretch        all          MariaDB database server (metapackage depending on the latest version)
      ii  mariadb-server-10.1           10.1.23+maria-1~stretch        amd64        MariaDB database server binaries
      ii  mariadb-server-core-10.1      10.1.23+maria-1~stretch        amd64        MariaDB database core server files
      ii  mysql-common                  5.8+1.0.2                      all          MySQL database common files, e.g. /etc/mysql/my.cnf
      

      However, the upgrade works on vanilla 10.4 (with old Galera), so the problem is most likely not in MariaDB server packaging, but in Galera's.

      This is some dark Debian magic, it happened before with different versions of MariaDB server, usually mariadb-server would refuse to install and would complain about mariadb-server-core-10.x not being installable, but the latter would install when it's done explicitly.

        Attachments

          Activity

            People

            Assignee:
            elenst Elena Stepanova
            Reporter:
            elenst Elena Stepanova
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated: