Uploaded image for project: 'MariaDB ColumnStore'
  1. MariaDB ColumnStore
  2. MCOL-3446

postconfigure upgrade failed - user running on Amazon AMI not using the Amazon AWS CLI Tools

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: N/A
    • Component/s: oam
    • Labels:
      None

      Description

      Customer report an postConfigure failure during an upgrade. I was able to reproduce it.

      Customer info:

      They did initial install using postConfigure like this:

      postConfigure -d -qm -pm-ip-addrs $(dig pm1 +short),$(dig pm2 +short) -um-ip-addrs $(dig um1 +short),$(dig um2 +short)

      When when they tried to do an upgrade, they got the below error:

      postConfigure -u

      This is the MariaDB ColumnStore System Configuration and Installation tool.
      It will Configure the MariaDB ColumnStore System and will perform a Package
      Installation of all of the Servers within the System that is being configured.
      :
      NOTE: Amazon AWS CLI Tools are installed and allow MariaDB ColumnStore
      to create Instances and EBS Volumes

      Do you want to have ColumnStore use the Amazon AWS CLI Tools [y,n] >

      Error: No IAM Profile with Security Certificates used or AWS CLI Certificate file configured
      Check Amazon Install Documenation for additional information, exiting...

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            hill David Hill (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Git Integration

                Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.